Medium, CVSS 6.1npmAmendedPublished
Cross-Site Scripting in serve-index
CVE-2015-8856 · GHSA-v633-x5vv-hqwc
- Affected
- npm serve-index < 1.6.3
- Fixed in
- 1.6.3· Vendor fix available
- Issue
- Versions 1.6.2 and earlier of serve-index are affected by a cross-site scripting vulnerability. Because file and directory names are not escaped in the module's HTML output, a remote attacker that can influence file or directory names can launch a persistent cross-site scripting attack on the application. Recommendation Update to version 1.6.3 or later.
Recommended action: Upgrade to 1.6.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.