Skip to content

← Public intelligence

npm package

send

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Low, CVSS 2.3npmAmendedPublished

    send vulnerable to template injection that can lead to XSS

    CVE-2024-43799 · GHSA-m6fv-jmcg-4jfg

    Affected
    • npm send < 0.19.0
    Fixed in
    0.19.0· Vendor fix available
    Issue
    Impact passing untrusted user input - even after sanitizing it - to SendStream.redirect() may execute untrusted code Patches this issue is patched in send 0.19.0 Workarounds users are encouraged to upgrade to the patched version of express, but otherwise can workaround this issue by making sure any untrusted inputs are safe, ideally by validating them against an explicit allowlist Details successful exploitation of this vector requires the following: 1. The attacker MUST control the input to response.redirect() 1. express MUST NOT redirect before the template appears 1. the browser MUST NOT complete redirection before: 1. the user MUST click on the link in the template

    Recommended action: Upgrade to 0.19.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Medium, CVSS 5.3npmAmendedPublished

    Root Path Disclosure in send

    CVE-2015-8859 · GHSA-jgqf-hwc5-hh37

    Affected
    • npm send < 0.11.1
    Fixed in
    0.11.1· Vendor fix available
    Issue
    Versions of send prior to 0.11.2 are affected by an information leakage vulnerability which may allow an attacker to enumerate paths on the server filesystem. Recommendation Update to version 0.11.1 or later.

    Recommended action: Upgrade to 0.11.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. UnratednpmAmendedPublished

    Directory Traversal in send

    CVE-2014-6394 · GHSA-xwg4-93c6-3h42

    Affected
    • npm send < 0.8.4
    Fixed in
    0.8.4· Vendor fix available
    Issue
    Versions 0.8.3 and earlier of send are affected by a directory traversal vulnerability. When relying on the root option to restrict file access it may be possible for an application consumer to escape out of the restricted directory and access files in a similarly named directory. For example, static(dirname + '/public') would allow access to dirname + '/public-restricted'. Recommendation Update to version 0.8.4 or later.

    Recommended action: Upgrade to 0.8.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →