Skip to content

← Public intelligence

npm package

semver

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.5npmAmendedPublished

    semver vulnerable to Regular Expression Denial of Service

    CVE-2022-25883 · GHSA-c2qf-rxjj-qqgw

    Affected
    • npm semver >= 7.0.0, < 7.5.2; >= 6.0.0, < 6.3.1; >= 2.0.0-alpha, < 5.7.2
    Fixed in
    5.7.26.3.17.5.2· Vendor fix available
    Issue
    Versions of the package semver before 7.5.2 on the 7.x branch, before 6.3.1 on the 6.x branch, and all other versions before 5.7.2 are vulnerable to Regular Expression Denial of Service (ReDoS) via the function new Range, when untrusted user data is provided as a range.

    Recommended action: Upgrade to 7.5.2, 6.3.1 or 5.7.2 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. High, CVSS 7.5npmAmendedPublished

    Regular Expression Denial of Service in semver

    CVE-2015-8855 · GHSA-x6fg-f45m-jf5q

    Affected
    • npm semver >= 1.0.4, < 4.3.2
    Fixed in
    4.3.2· Vendor fix available
    Issue
    Versions 4.3.1 and earlier of semver are affected by a regular expression denial of service vulnerability when extremely long version strings are parsed. Recommendation Update to version 4.3.2 or later

    Recommended action: Upgrade to 4.3.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →