Skip to content

← Public intelligence

npm package

restify

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.1npmAmendedPublished

    Cross-Site Scripting (XSS) in restify

    CVE-2017-16018 · GHSA-qw3g-35hc-fcrh

    Affected
    • npm restify >= 2.0.0, <= 4.0.4
    Fixed in
    4.1.0· Vendor fix available
    Issue
    Affected versions of restify are susceptible to a cross-site scripting vulnerability when using URL encoded script tags in a non-existent URL. Proof of Concept: Request Will be included in response: Recommendation Update to version 4.1.0 or later.

    Recommended action: Upgrade to 4.1.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →