High, CVSS 7.1npmAmendedPublished
react-pdf vulnerable to arbitrary JavaScript execution upon opening a malicious PDF with PDF.js
CVE-2024-34342 · GHSA-87hq-q4gp-9wr4
- Affected
- npm react-pdf < 7.7.3; >= 8.0.0, < 8.0.2
- Fixed in
- 8.0.27.7.3· Vendor fix available
- Issue
- If PDF.js is used to load a malicious PDF, and PDF.js is configured with isEvalSupported set to true (which is the default value), unrestricted attacker-controlled JavaScript will be executed in the context of the hosting domain. Patches This patch forces isEvalSupported to false, removing the attack vector. Workarounds Set options.isEvalSupported to false, where options is Document component prop. References - GHSA-wgrm-67xf-hhpq - https://github.com/mozilla/pdf.js/pull/18015 - https://github.com/mozilla/pdf.js/commit/85e64b5c16c9aaef738f421733c12911a441cec6 - https://bugzilla.mozilla.org/showbug.cgi?id=1893645
Recommended action: Upgrade to 8.0.2 or 7.7.3 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.