Skip to content

← Public intelligence

npm package

raneto

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.5npmAmendedPublished

    Raneto Denial of Service via crafted payload injected into Search parameter

    CVE-2022-35142 · GHSA-xxc2-j7jj-6g5m

    Affected
    • npm raneto <= 0.17.0
    Fixed in
    0.17.1· Vendor fix available
    Issue
    An issue in Renato v0.17.0 allows attackers to cause a Denial of Service (DoS) via a crafted payload injected into the Search parameter.

    Recommended action: Upgrade to 0.17.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Critical, CVSS 9.8npmAmendedPublished

    Raneto v0.17.0 employs weak password complexity requirements

    CVE-2022-35143 · GHSA-7942-2fx8-qhpf

    Affected
    • npm raneto <= 0.17.0
    Fixed in
    0.17.1· Vendor fix available
    Issue
    Raneto v0.17.0 employs weak password complexity requirements, allowing attackers to crack user passwords via brute-force attacks. Version 0.17.1 contains security mitigations for this and other vulnerabilities.

    Recommended action: Upgrade to 0.17.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. Medium, CVSS 4.8npmAmendedPublished

    Raneto vulnerable to Cross-site Scripting

    CVE-2022-35144 · GHSA-vc68-6x72-w22f

    Affected
    • npm raneto <= 0.17.0
    Fixed in
    0.17.1· Vendor fix available
    Issue
    Renato v0.17.0 was discovered to contain a cross-site scripting (XSS) vulnerability. This issue is fixed in version 0.17.1.

    Recommended action: Upgrade to 0.17.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →