High, CVSS 8.8npmAmendedPublished
pym.js CSRF Vulnerability
CVE-2018-1000086 · GHSA-82gw-pqf7-q3j2
- Affected
- npm pym.js >= 0.4.2, <= 1.3.1
- Fixed in
- 1.3.2· Vendor fix available
- Issue
- NPR Visuals Team Pym.js version versions 0.4.2 up to 1.3.1 contains a Cross Site Request Forgery (CSRF) vulnerability in Pym.js onNavigateToMessage function. https://github.com/nprapps/pym.js/blob/master/src/pym.js#L573 can result in Arbitrary javascript code execution. This attack appears to be exploitable if the Attacker gains full javascript access to pages with Pym.js embeds, or when user visits an attacker-crafted page. This vulnerability appears to have been fixed in versions 1.3.2 and later.
Recommended action: Upgrade to 1.3.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.