Skip to content

← Public intelligence

npm package

putil-merge

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.2npmAmendedPublished

    Prototype Pollution in putil-merge

    CVE-2021-23470 · GHSA-4g77-cvgw-grvw

    Affected
    • npm putil-merge < 3.8.0
    Fixed in
    3.8.0· Vendor fix available
    Issue
    This affects the package putil-merge before 3.8.0. The merge() function does not check the values passed into the argument. An attacker can supply a malicious value by adjusting the value to include the constructor property. Note: This vulnerability derives from an incomplete fix in https://security.snyk.io/vuln/SNYK-JS-PUTILMERGE-1317077

    Recommended action: Upgrade to 3.8.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Critical, CVSS 9.8npmAmendedPublished

    Prototype Pollution in putil-merge

    CVE-2021-25953 · GHSA-9x7m-9hpg-xxmw

    Affected
    • npm putil-merge >= 1.0.0, <= 3.6.6
    Fixed in
    3.7.0· Vendor fix available
    Issue
    Prototype pollution vulnerability in 'putil-merge' versions1.0.0 through 3.6.6 allows attacker to cause a denial of service and may lead to remote code execution.

    Recommended action: Upgrade to 3.7.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →