Skip to content

← Public intelligence

npm package

public

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

4 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. UnratednpmAmendedPublished

    Cross-Site Scripting in public

    GHSA-7jfh-2xc9-ccv7

    Affected
    • npm public < 0.1.4; >= 0.1.5, <= 0.1.5
    Fixed in
    0.1.4· Partial vendor fix
    Issue
    All versions of public are vulnerable to stored cross-site scripting (XSS). Recommendation No fix is currently available for this vulnerability. It is our recommendation to not install or use this module at this time.

    Recommended action: Upgrade to 0.1.4; some affected versions have no fix yet, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Medium, CVSS 6.1npmAmendedPublished

    Tnantoka/public XSS Vulnerability

    CVE-2018-16480 · GHSA-649c-x44h-4q7v

    Affected
    • npm public < 0.1.4
    Fixed in
    0.1.4· Vendor fix available
    Issue
    A XSS vulnerability was found in module public <0.1.4 that allows malicious Javascript code to run in the browser, due to the absence of sanitization of the file/folder names before rendering.

    Recommended action: Upgrade to 0.1.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. Medium, CVSS 6.1npmAmendedPublished

    Cross-Site Scripting in public

    CVE-2018-3747 · GHSA-8p5p-ff7x-hw7q

    Affected
    • npm public < 0.1.4
    Fixed in
    0.1.4· Vendor fix available
    Issue
    Versions of public prior to 0.1.4 are vulnerable to Cross-Site Scripting (XSS). The package fails to sanitize filenames, allowing attackers to execute arbitrary JavaScript in the victim's browser through files with names containing malicious code. Recommendation Upgrade to version 0.1.4 or later.

    Recommended action: Upgrade to 0.1.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  4. High, CVSS 7.5npmAmendedPublished

    Path Traversal in public

    CVE-2018-3731 · GHSA-rwv8-jvff-jq28

    Affected
    • npm public <= 0.1.2
    Fixed in
    0.1.3· Vendor fix available
    Issue
    Versions of public before 0.1.3 are vulnerable to path traversal. This is due to lack of file path sanitization which could lead to any file the parent process has access to on the server to be read by malicious user. Recommendation Update to version 0.1.3 or later.

    Recommended action: Upgrade to 0.1.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →