High, CVSS 7.5npmAmendedPublished
proxy denial of service vulnerability
CVE-2023-2968 · GHSA-mj6p-3pc9-wf5m
- Affected
- npm proxy >= 2.0.0, < 2.1.1
- Fixed in
- 2.1.1· Vendor fix available
- Issue
- A remote attacker can trigger a denial of service in the socket.remoteAddress variable, by sending a crafted HTTP request. Usage of the undefined variable raises a TypeError exception.
Recommended action: Upgrade to 2.1.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.