Critical, CVSS 9.8npmAmendedPublished
promise-probe OS command injection vulnerability
CVE-2019-10791 · GHSA-vmqq-7qvx-68qx
- Affected
- npm promise-probe < 0.1.10
- Fixed in
- 0.1.10· Vendor fix available
- Issue
- promise-probe before 0.10.0 allows remote attackers to perform a command injection attack. The file, outputFile and options functions can be controlled by users without any sanitization.
Recommended action: Upgrade to 0.1.10 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.