High, CVSS 8.6npmAmendedPublished
Prebid.js NPM package briefly compromised
CVE-2025-59038 · GHSA-jwq7-6j4r-2f92
- Affected
- npm prebid.js >= 10.9.2, <= 10.9.2
- Fixed in
- 10.10.0· Vendor fix available
- Issue
- Impact NPM users of prebid 10.9.2. The malicious code attempts to redirect crypto transactions on the site to the attackers' wallet. Patches 10.10.0 is solved References https://www.sonatype.com/blog/npm-chalk-and-debug-packages-hit-in-software-supply-chain-attack
Recommended action: Upgrade to 10.10.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.