Skip to content

← Public intelligence

npm package

payload

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

28 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.3npmAmendedPublished

    Payload's SQLite adapter Session Fixation vulnerability

    CVE-2025-4644 · GHSA-26rv-h2hf-3fw4

    Affected
    • npm payload < 3.44.0
    Fixed in
    3.44.0· Vendor fix available
    Issue
    A Session Fixation vulnerability existed in Payload's SQLite adapter due to identifier reuse during account creation. A malicious attacker could create a new account, save its JSON Web Token (JWT), and then delete the account, which did not invalidate the JWT. As a result, the next newly created user would receive the same identifier, allowing the attacker to reuse the JWT to authenticate and perform actions as that user. This issue has been fixed in version 3.44.0 of Payload.

    Recommended action: Upgrade to 3.44.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. High, CVSS 7.4npmAmendedPublished

    Hidden fields can be leaked on readable collections in Payload

    CVE-2023-30843 · GHSA-35jj-vqcf-f2jf

    Affected
    • npm payload < 1.7.0
    Fixed in
    1.7.0· Vendor fix available
    Issue
    Details If a user has access to documents that contain hidden fields or fields they do not have access to, the user could reverse-engineer those values via brute force. Affected versions: < 1.7.0 Workarounds If you are unable to update, you can write a beforeOperation hook to remove where queries that attempt to access hidden field data. Detecting Compromise Monitor your instance for brute-force style requests against your instance using where queries.

    Recommended action: Upgrade to 1.7.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. Critical, CVSS 9.8npmAmendedPublished

    Unrestricted Upload of File with Dangerous Type in Payload

    CVE-2022-27952 · GHSA-w8xh-93qh-35vw

    Affected
    • npm payload <= 0.15.0
    Fixed in
    0.15.1· Vendor fix available
    Issue
    An arbitrary file upload vulnerability in the file upload module of PayloadCMS v0.15.0 allows attackers to execute arbitrary code via a crafted SVG file.

    Recommended action: Upgrade to 0.15.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →