High, CVSS 8.1npmAmendedPublished
Authentication Bypass in passport-azure-ad
CVE-2016-7191 · GHSA-73jp-3c67-hjfv
- Affected
- npm passport-azure-ad >= 1.0.0, < 1.4.6; >= 2.0.0, <= 2.0.0
- Fixed in
- 2.0.11.4.6· Vendor fix available
- Issue
- Affected versions of passport-azure-ad do not recognize the validateIssuer setting, which allows remote attackers to bypass authentication via a crafted token. Recommendation Version 1.x: Update to version 1.4.6 or later. Version 2.x: Update to version 2.0.1 or later.
Recommended action: Upgrade to 2.0.1 or 1.4.6 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.