High, CVSS 7.7npmAmendedPublished
pacote is vulnerable to Denial of Service (DoS) via the addGitSha function
CVE-2026-9496 · GHSA-w4pp-8pjf-rmxw
- Affected
- npm pacote >= 11.2.7, < 21.5.1
- Fixed in
- 21.5.1· Vendor fix available
- Issue
- Versions of the package pacote from 11.2.7 are vulnerable to Denial of Service (DoS) via the addGitSha function. An attacker can exploit this vulnerability by supplying a specially crafted spec.rawSpec value that triggers the function’s regex replacement and string-manipulation logic, causing excessive CPU consumption and potentially stalling or crashing the process.
Recommended action: Upgrade to 21.5.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.