Skip to content

← Public intelligence

npm package

openlearnx

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.9npmAmendedPublished

    OpenLearnX: Critical Authentication Bypass via JWT Signature Verification Disabled Leading to Account Takeover

    CVE-2026-44720 · GHSA-223g-f5mq-gw33

    Affected
    • npm openlearnx < 2.0.4
    Fixed in
    2.0.4· Vendor fix available
    Issue
    A critical authentication vulnerability was identified in OpenLearnX that could allow unauthorized access to user accounts under specific conditions. The issue has been fixed. Advisory: https://github.com/th30d4y/OpenLearnX/security/advisories/GHSA-223g-f5mq-gw33

    Recommended action: Upgrade to 2.0.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. High, CVSS 8.8npmAmendedPublished

    OpenLearnX has Critical Remote Code Execution Through Python Sandbox Escape via Code Execution Environment

    CVE-2026-41900 · GHSA-8h25-q488-4hxw

    Affected
    • npm openlearnx < 2.0.3
    Fixed in
    2.0.3· Vendor fix available
    Issue
    A critical Remote Code Execution (RCE) vulnerability was identified in the OpenLearnX code execution environment, allowing sandbox escape and arbitrary command execution. The issue has been fixed.

    Recommended action: Upgrade to 2.0.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →