High, CVSS 7.8npmAmendedPublished
Obsidian Dataview vulnerable to code injection due to unsafe eval
CVE-2021-42057 · GHSA-xfg5-vrmc-24wc
- Affected
- npm obsidian-dataview <= 0.4.12-hotfix1
- Fixed in
- 0.4.13· Vendor fix available
- Issue
- Obsidian Dataview through 0.4.12-hotfix1 allows eval injection. The evalInContext function in executes user input, which allows an attacker to craft malicious Markdown files that will execute arbitrary code once opened. NOTE: 0.4.13 provides a mitigation for some use cases.
Recommended action: Upgrade to 0.4.13 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.