Medium, CVSS 6.6npmAmendedPublished
nope-validator Regular Expression Denial of Service vulnerability
CVE-2020-26309 · GHSA-3phv-83cj-p8p7
- Affected
- npm nope-validator < 0.12.1
- Fixed in
- 0.12.1· Vendor fix available
- Issue
- Nope is a JavaScript validator. Versions 0.11.3 and prior contain one or more regular expressions that are vulnerable to Regular Expression Denial of Service (ReDoS). This vulnerability is fixed in 0.12.1.
Recommended action: Upgrade to 0.12.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.