Critical, CVSS 9.8npmAmendedPublished
nodebatis SQL Injection vulnerability
CVE-2018-25066 · GHSA-8ph8-9q2j-c3rq
- Affected
- npm nodebatis < 2.2.0
- Fixed in
- 2.2.0· Vendor fix available
- Issue
- A vulnerability was found in PeterMu nodebatis up to 2.1.x. It has been classified as critical. Affected is an unknown function. The manipulation leads to sql injection. Upgrading to version 2.2.0 can address this issue. The name of the patch is 6629ff5b7e3d62ad8319007a54589ec1f62c7c35. It is recommended to upgrade the affected component. VDB-217554 is the identifier assigned to this vulnerability.
Recommended action: Upgrade to 2.2.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.