Critical, CVSS 9.8npmAmendedPublished
Prototype Pollution in node.extend
CVE-2018-16491 · GHSA-r96c-57pf-9jjm
- Affected
- npm node.extend < 1.1.7; >= 2.0.0, <= 2.0.0
- Fixed in
- 2.0.11.1.7· Vendor fix available
- Issue
- Versions of node.extend before 1.1.7 or 2.0.1 are vulnerable to prototype pollution. Recommendation Update to version 1.1.7, 2.0.1 or later.
Recommended action: Upgrade to 2.0.1 or 1.1.7 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.