Skip to content

← Public intelligence

npm package

node-weakauras-parser

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. UnratednpmAmendedPublished

    Buffer Overflow in node-weakauras-parser

    GHSA-86mr-6m89-vgj3

    Affected
    • npm node-weakauras-parser >= 1.0.4, < 1.0.5; >= 2.0.0, < 2.0.2; >= 3.0.0, < 3.0.1
    Fixed in
    3.0.12.0.21.0.5· Vendor fix available
    Issue
    Affected versions of node-weakauras-parser are vulnerable to a Buffer Overflow. The encodeweakaura function fails to properly validate the input size. A buffer of 13835058055282163711 bytes causes an overflow on 64-bit systems. Recommendation Upgrade to versions 1.0.5, 2.0.2, 3.0.1 or later.

    Recommended action: Upgrade to 3.0.1, 2.0.2 or 1.0.5 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →