Skip to content

← Public intelligence

npm package

node-simple-router

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.5npmAmendedPublished

    Directory Traversal in node-simple-router

    CVE-2017-16083 · GHSA-5w8q-x7hc-jhp6

    Affected
    • npm node-simple-router <= 0.10.0
    Fixed in
    0.10.1· Vendor fix available
    Issue
    Affected versions of node-simple-router resolve relative file paths, resulting in a directory traversal vulnerability. A malicious actor can use this vulnerability to access files outside of the intended directory root, which may result in the disclosure of private files on the vulnerable system. Example request: Recommendation Update to v0.10.1 or later.

    Recommended action: Upgrade to 0.10.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →