Critical, CVSS 9.8npmAmendedPublished
Code Injection in node-rules
CVE-2020-7609 · GHSA-f78f-353m-cf4j
- Affected
- npm node-rules >= 3.0.0, < 5.0.0
- Fixed in
- 5.0.0· Vendor fix available
- Issue
- node-rules including 3.0.0 and prior to 5.0.0 allows injection of arbitrary commands. The argument rules of function "fromJSON()" can be controlled by users without any sanitization.
Recommended action: Upgrade to 5.0.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.