Skip to content

← Public intelligence

npm package

node-red

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. UnratednpmAmendedPublished

    Cross-Site Scripting in node-red

    GHSA-5g6j-8hv4-vfgj

    Affected
    • npm node-red < 0.18.6
    Fixed in
    0.18.6· Vendor fix available
    Issue
    Versions of node-red prior to 0.18.6 are vulnerable to Cross-Site Scripting (XSS). The package fails to sanitize the name field in new items, allowing attackers to execute arbitrary JavaScript in the victim's browser. Recommendation Upgrade to version 0.18.6 or later.

    Recommended action: Upgrade to 0.18.6 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Medium, CVSS 5.4npmAmendedPublished

    Cross-Site Scripting in node-red

    CVE-2019-15607 · GHSA-8w65-xjc5-9w79

    Affected
    • npm node-red <= 0.20.7
    Fixed in
    0.20.8· Vendor fix available
    Issue
    Versions of node-red prior to 0.20.8are vulnerable to Cross-Site Scripting (XSS). The package fails to sanitize the name field in new Flows, allowing attackers to execute arbitrary JavaScript in the victim's browser. Recommendation Upgrade to version 0.18.6 or later.

    Recommended action: Upgrade to 0.20.8 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →