High, CVSS 7.5npmAmendedPublished
Unauthorized File Access in node-git-server
GHSA-cv3v-7846-6pxm
- Affected
- npm node-git-server >= 0.2.0, < 0.6.1
- Fixed in
- 0.6.1· Vendor fix available
- Issue
- Versions of node-git-server prior to 0.6.1 are vulnerable to Unauthorized File Access. It is possible to access any git repository by using absolute paths, which may allow attackers to access private repositories. Recommendation Upgrade to version 0.6.1 or later.
Recommended action: Upgrade to 0.6.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.