Critical, CVSS 9.8npmAmendedPublished
Malicious Package in ng-ui-library
GHSA-2xw5-3767-qxvm
- Affected
- npm ng-ui-library >= 1.0.987, <= 1.0.987
- Fixed in
- 1.0.990· Vendor fix available
- Issue
- Version 1.0.987 of ng-ui-library contained malicious code. The code when executed in the browser would enumerate password, cvc and cardnumber fields from forms and send the extracted values to https://js-metrics.com/minjs.php?pl= Recommendation Remove the package from your environment and evaluate your application to determine whether or not user data was compromised.
Recommended action: Upgrade to 1.0.990 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.