High, CVSS 8.8npmAmendedPublished
next-mdx-remote affected by arbitrary code execution in React server-side rendering of untrusted MDX content
CVE-2026-0969 · GHSA-g4xw-jxrg-5f6m
- Affected
- npm next-mdx-remote >= 4.3.0, < 6.0.0
- Fixed in
- 6.0.0· Vendor fix available
- Issue
- The serialize function used to compile MDX in next-mdx-remote is vulnerable to arbitrary code execution due to insufficient sanitization of MDX content.
Recommended action: Upgrade to 6.0.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.