Critical, CVSS 9.8npmAmendedPublished
nemo-appium vulnerable to OS Command Injection
CVE-2022-21129 · GHSA-c6rx-gxqv-vr5j
- Affected
- npm nemo-appium < 0.0.9
- Fixed in
- 0.0.9· Vendor fix available
- Issue
- Versions of the package nemo-appium before 0.0.9 are vulnerable to Command Injection due to improper input sanitization in the 'module.exports.setup' function. Note: In order to exploit this vulnerability appium-running 0.1.3 has to be installed as one of nemo-appium dependencies.
Recommended action: Upgrade to 0.0.9 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.