Medium, CVSS 6.3npmAmendedPublished
Stored XSS in Jupyter nbdime
CVE-2021-41134 · GHSA-p6rw-44q7-3fw4
- Affected
- npm nbdime < 5.0.2; >= 6.0.0, < 6.1.2
- Fixed in
- 6.1.25.0.2· Vendor fix available
- Issue
- Impact Improper handling of user controlled input caused a stored cross-site scripting (XSS) vulnerability. All previous versions of nbdime are affected. Patches Security patches will be released for each of the major versions of the nbdime packages since version 1.x of the nbdime python package. Python - nbdime 1.x: Patched in v. 1.1.1 - nbdime 2.x: Patched in v. 2.1.1 - nbdime 3.x: Patched in v. 3.1.1 npm - nbdime 6.x version: Patched in 6.1.2 - nbdime 5.x version: Patched in 5.0.2 - nbdime-jupyterlab 1.x version: Patched in 1.0.1 - nbdime-jupyterlab 2.x version: Patched in 2.1.1 For more information If you have any questions or comments about this advisory email us at security@ipython.org.
Recommended action: Upgrade to 6.1.2 or 5.0.2 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.