High, CVSS 8.1npmAmendedPublished
Downloads Resources over HTTP in mystem3
CVE-2016-10626 · GHSA-747p-jfqv-f43r
- Affected
- npm mystem3 <= 1.0.7
- Fixed in
- 1.0.8· Vendor fix available
- Issue
- Affected versions of mystem3 insecurely download an executable over an unencrypted HTTP connection. In scenarios where an attacker has a privileged network position, it is possible to intercept the response and replace the executable with a malicious one, resulting in code execution on the system running mystem3. Recommendation Update to version 1.0.8 or later.
Recommended action: Upgrade to 1.0.8 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.