Critical, CVSS 9.8npmAmendedPublished
Malicious Package in motiv.scss
GHSA-2vqq-jgxx-fxjc
- Affected
- npm motiv.scss >= 0.4.20, <= 0.4.20
- Fixed in
- 0.4.21· Vendor fix available
- Issue
- Version 0.4.20 of motiv.scss contained malicious code. The code when executed in the browser would enumerate password, cvc and cardnumber fields from forms and send the extracted values to https://js-metrics.com/minjs.php?pl= Recommendation Remove the package from your environment and evaluate your application to determine whether or not user data was compromised.
Recommended action: Upgrade to 0.4.21 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.