Skip to content

← Public intelligence

npm package

mongodb-query-parser

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 9.8npmAmendedPublished

    Remote code execution in mongo-express

    CVE-2020-24391 · GHSA-hxmg-hm46-cf62

    Affected
    • npm mongodb-query-parser < 2.0.0
    Fixed in
    2.0.0· Vendor fix available
    Issue
    mongo-express before 1.0.0 offers support for certain advanced syntax but implements this in an unsafe way. NOTE: this may overlap CVE-2019-10769.

    Recommended action: Upgrade to 2.0.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. UnratednpmAmendedPublished

    Remote Code Execution in mongodb-query-parser

    GHSA-97mg-3cr6-3x4c

    Affected
    • npm mongodb-query-parser < 2.0.0
    Fixed in
    2.0.0· Vendor fix available
    Issue
    Versions of mongodb-query-parser prior to 2.0.0 are vulnerable to Remote Code Execution. The package fails to sanitize queries, allowing attackers to execute arbitrary code in the system. Parsing the following payload executes touch test-file: Recommendation Upgrade to version 2.0.0 or later.

    Recommended action: Upgrade to 2.0.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →