Medium, CVSS 5.5npmAmendedPublished
mcp-server-semgrep has a Command Injection issue
CVE-2026-7446 · GHSA-86hp-qxqp-w9wv
- Affected
- npm mcp-server-semgrep <= 1.0.0
- Fixed in
- 1.0.1· Vendor fix available
- Issue
- A vulnerability was detected in VetCoders mcp-server-semgrep 1.0.0. This affects the function analyzeresults/filterresults/exportresults/compareresults/scandirectory/createrule of the file src/index.ts of the component MCP Interface. The manipulation of the argument ID results in os command injection. The attack can be executed remotely. The exploit is now public and may be used. Upgrading to version 1.0.1 is able to mitigate this issue. The patch is identified as 141335da044e53c3f5b315e0386e01238405b771. It is advisable to upgrade the affected component.
Recommended action: Upgrade to 1.0.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.