High, CVSS 7.5npmAmendedPublished
mcp-markdownify-server vulnerable to command injection in pptx-to-markdown tool
CVE-2025-58358 · GHSA-45qj-4xq3-3c45
- Affected
- npm mcp-markdownify-server <= 0.0.1
- Fixed in
- 0.0.2· Vendor fix available
- Issue
- A command injection vulnerability exists in the mcp-markdownify-server MCP Server. The vulnerability is caused by the unsanitized use of input parameters within a call to childprocess.exec, enabling an attacker to inject arbitrary system commands. Successful exploitation can lead to remote code execution under the server process's privileges. The server constructs and executes shell commands using unvalidated user input directly within command-line strings. This introduces the possibility of shell metacharacter injection (|, , &&, etc.). Details The MCP Server exposes tools to perform several file operations. An MCP Client can be instructed to execute additional actions for example via indirect prompt injection when asked to read an md file. Below some example of vulnerable code and different ways to test this vulnerability including a real example of indirect prompt injection that can lead to arbitrary command injection. Vulnerable code The following snippet illustrates the…
Recommended action: Upgrade to 0.0.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.