Medium, CVSS 5.3npmAmendedPublished
mcp-maigret vulnerable to command injection
CVE-2026-2130 · GHSA-2g7v-hghf-grg4
- Affected
- npm mcp-maigret < 1.0.13
- Fixed in
- 1.0.13· Vendor fix available
- Issue
- A vulnerability was determined in BurtTheCoder mcp-maigret up to 1.0.12. This affects an unknown part of the file src/index.ts of the component searchusername. Executing a manipulation of the argument Username can lead to command injection. The attack may be launched remotely. Upgrading to version 1.0.13 is able to mitigate this issue. This patch is called b1ae073c4b3e789ab8de36dc6ca8111ae9399e7a. Upgrading the affected component is advised.
Recommended action: Upgrade to 1.0.13 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.