High, CVSS 8.0npmAmendedPublished
Improper handling of multiline messages in node-irc
GHSA-52rh-5rpj-c3w6
- Affected
- npm matrix-org-irc <= 1.2.0
- Fixed in
- 1.2.1· Vendor fix available
- Issue
- node-irc is a socket wrapper for the IRC protocol that extends Node.js' EventEmitter. The vulnerability allows an attacker to manipulate a Matrix user into executing IRC commands by having them reply to a maliciously crafted message. Incorrect handling of a CR character allowed for making part of the message be sent to the IRC server verbatim rather than as a message to the channel. The vulnerability has been patched in node-irc version 1.2.1.
Recommended action: Upgrade to 1.2.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.