Skip to content

← Public intelligence

npm package

markdown-to-jsx

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.3npmAmendedPublished

    Cross site scripting in markdown-to-jsx

    CVE-2024-21535 · GHSA-4wx3-54gh-9fr9

    Affected
    • npm markdown-to-jsx < 7.4.0
    Fixed in
    7.4.0· Vendor fix available
    Issue
    Versions of the package markdown-to-jsx before 7.4.0 are vulnerable to Cross-site Scripting (XSS) via the src property due to improper input sanitization. An attacker can execute arbitrary code by injecting a malicious iframe element in the markdown.

    Recommended action: Upgrade to 7.4.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. UnratednpmAmendedPublished

    Cross-Site Scripting in markdown-to-jsx

    GHSA-ccrp-c664-8p4j

    Affected
    • npm markdown-to-jsx < 6.11.4
    Fixed in
    6.11.4· Vendor fix available
    Issue
    Versions of markdown-to-jsx prior to 6.11.4 are vulnerable to Cross-Site Scripting. Due to insufficient input sanitization the package may render output containing malicious JavaScript. This vulnerability can be exploited through input of links containing data or VBScript URIs and a base64-encoded payload. Recommendation Upgrade to version 6.11.4 or later.

    Recommended action: Upgrade to 6.11.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →