Critical, CVSS 9.8npmAmendedPublished
Malicious Package in load-from-cwd-or-npm
GHSA-jxf5-7x3j-8j9m
- Affected
- npm load-from-cwd-or-npm >= 3.0.2, <= 3.0.2
- Fixed in
- 3.0.4· Vendor fix available
- Issue
- Version 3.0.2 of load-from-cwd-or-npm contains malicious code. The malware breaks functionality of the purescript-installer package by injecting targeted code. Recommendation Upgrade to version 3.0.4 or later. There is no indication of further compromise.
Recommended action: Upgrade to 3.0.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.