Low, CVSS 3.8npmAmendedPublished
Command Injection in Limdu
CVE-2020-4066 · GHSA-77qv-gh6f-pgh4
- Affected
- npm limdu <= 0.9.4
- Fixed in
- 0.9.5· Vendor fix available
- Issue
- Impact The trainBatch function has a command injection vulnerability. Clients of the Limdu library are unlikely to be aware of this, so they might unwittingly write code that contains a vulnerability. Patches Patched in version 0.9.5. Workarounds Do not use trainBatch with classifiers that rely on shell execution, such as SVM Perf, SVM Linear or Adaboost References No
Recommended action: Upgrade to 0.9.5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.