High, CVSS 8.7npmAmendedPublished
lilconfig Code Injection vulnerability
CVE-2024-21537 · GHSA-fq9m-v26v-2m4f
- Affected
- npm lilconfig >= 3.1.0, < 3.1.1
- Fixed in
- 3.1.1· Vendor fix available
- Issue
- Versions of the package lilconfig from 3.1.0 and before 3.1.1 are vulnerable to Arbitrary Code Execution due to the insecure usage of eval in the dynamicImport function. An attacker can exploit this vulnerability by passing a malicious input through the defaultLoaders function.
Recommended action: Upgrade to 3.1.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.