High, CVSS 8.8npmAmendedPublished
OS Command Injection in lifion-verify-deps
CVE-2021-34078 · GHSA-rphm-c8gw-3r38
- Affected
- npm lifion-verify-deps < 1.2.0
- Fixed in
- 1.2.0· Vendor fix available
- Issue
- lifion-verify-dependencies through 1.1.0 is vulnerable to OS command injection via a crafted dependency name on the scanned project's package.json file.
Recommended action: Upgrade to 1.2.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.