UnratednpmAmendedPublished
Heap Based Buffer Overflow in libyaml
CVE-2013-6393 · GHSA-m75h-cghq-c8h5
- Affected
- npm libyaml < 0.2.3
- Fixed in
- 0.2.3· Vendor fix available
- Issue
- Versions 0.2.2 and earlier depend on native libyaml version 0.1.5 or earlier. As such, they are affected by a heap-based buffer overflow vulnerability that may result in a crash or arbitrary code execution when parsing YAML tags. Recommendation - Update to version 0.2.3 that includes a version of LibYAML that contains a fix for this issue.
Recommended action: Upgrade to 0.2.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.