High, CVSS 7.5npmAmendedPublished
pg-native and libpq vulnerable to uncontrolled resource consumption
CVE-2022-25852 · GHSA-j32j-2hxv-rqf7
- Affected
- npm libpq <= 1.8.9
- Fixed in
- 1.8.10· Vendor fix available
- Issue
- pg-native before 3.0.1 and libpq before 1.8.10 are vulnerable to Denial of Service (DoS) when the addons attempt to cast the second argument to an array and fail. This happens for every non-array argument passed. Note: pg-native is a mere binding to npm's libpq library, which in turn has the addons and bindings to the actual C libpq library. This means that problems found in pg-native may transitively impact npm's libpq.
Recommended action: Upgrade to 1.8.10 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.