Skip to content

← Public intelligence

npm package

knex

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.5npmAmendedPublished

    Knex.js has a limited SQL injection vulnerability

    CVE-2016-20018 · GHSA-4jv9-3563-23j3

    Affected
    • npm knex < 2.4.0
    Fixed in
    2.4.0· Vendor fix available
    Issue
    Knex Knex.js through 2.3.0 has a limited SQL injection vulnerability that can be exploited to ignore the WHERE clause of a SQL query. This vulnerability has been fixed in version 2.4.0.

    Recommended action: Upgrade to 2.4.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Critical, CVSS 9.8npmAmendedPublished

    SQL Injection in knex

    CVE-2019-10757 · GHSA-58v4-qwx5-7f59

    Affected
    • npm knex < 0.19.5
    Fixed in
    0.19.5· Vendor fix available
    Issue
    knex.js versions before 0.19.5 are vulnerable to SQL Injection attack. Identifiers are escaped incorrectly as part of the MSSQL dialect, allowing attackers to craft a malicious query to the host DB.

    Recommended action: Upgrade to 0.19.5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →