High, CVSS 7.5npmAmendedPublished
Validation Bypass in kind-of
CVE-2019-20149 · GHSA-6c8f-qphg-qjgp
- Affected
- npm kind-of >= 6.0.0, < 6.0.3
- Fixed in
- 6.0.3· Vendor fix available
- Issue
- Versions of kind-of 6.x prior to 6.0.3 are vulnerable to a Validation Bypass. A maliciously crafted object can alter the result of the type check, allowing attackers to bypass the type checking validation. Recommendation Upgrade to versions 6.0.3 or later.
Recommended action: Upgrade to 6.0.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.