Critical, CVSS 9.8npmAmendedPublished
Prototype polluation in just-safe-set
CVE-2021-25952 · GHSA-v26w-gcxh-v4r7
- Affected
- npm just-safe-set >= 1.0.0, < 2.2.2
- Fixed in
- 2.2.2· Vendor fix available
- Issue
- Prototype pollution vulnerability in ‘just-safe-set’ versions 1.0.0 through 2.2.1 allows an attacker to cause a denial of service and may lead to remote code execution.
Recommended action: Upgrade to 2.2.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.