Skip to content

← Public intelligence

npm package

jsuites

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.1npmAmendedPublished

    jSuites subect to Cross-site Scripting

    CVE-2022-25979 · GHSA-r4hg-4cpq-q57c

    Affected
    • npm jsuites < 5.0.1
    Fixed in
    5.0.1· Vendor fix available
    Issue
    Versions of the package jsuites before 5.0.1 are vulnerable to Cross-site Scripting (XSS) due to improper user-input sanitization in the Editor() function.

    Recommended action: Upgrade to 5.0.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. High, CVSS 8.7npmAmendedPublished

    Clipboard-based XSS

    CVE-2021-41086 · GHSA-qh7x-j4v8-qw5w

    Affected
    • npm jsuites < 4.9.11
    Fixed in
    4.9.11· Vendor fix available
    Issue
    Impact XSS against the user. Details jsuites is vulnerable to DOM based XSS if the user can be tricked into copying anything from a malicious and pasting it into the html editor. This is because a part of the clipboard content is directly written to innerHTML causing XSS. References The Curious Case of Copy & Paste – on risks of pasting arbitrary content in browsers: https://research.securitum.com/the-curious-case-of-copy-paste/

    Recommended action: Upgrade to 4.9.11 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →