Medium, CVSS 6.3npmAmendedPublished
Template Injection in jsrender
CVE-2016-3942 · GHSA-r87w-47m8-22w3
- Affected
- npm jsrender <= 0.9.73
- Fixed in
- 0.9.74· Vendor fix available
- Issue
- Affected versions of jsrender are susceptible to a remote code execution vulnerability when used with server delivered client-side tempates which dynamically embed user input. Proof of Concept Recommendation Update to version 0.9.74 or later.
Recommended action: Upgrade to 0.9.74 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.