Skip to content

← Public intelligence

npm package

jquery.terminal

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Low, CVSS 3.7npmAmendedPublished

    jquery.terminal self XSS on user input

    CVE-2021-43862 · GHSA-x9r5-jxvq-4387

    Affected
    • npm jquery.terminal < 2.31.1
    Fixed in
    2.31.1· Vendor fix available
    Issue
    Impact This is low impact and limited XSS, because code for XSS payload is always visible, but attacker can use other techniques to hide the code the victim sees. Also if the application use execHash option and execute code from URL the attacker can use this URL to execute his code. The scope is limited because the javascript code inside html attribute used is added to span tag, so no automatic execution like with onerror on images is possible. Patches Fixed version 2.31.1 Workarounds The user can use formatting that wrap whole user input and it's no op. The fix will only work when user of the library is not using different formatters (e.g. to highlight code in different way). References The issue was reported here jcubic/jquery.terminal#727 For more information If you have any questions or comments about this advisory: Open an issue in jcubic/jquery.terminal Email us at jcubic@onet.pl

    Recommended action: Upgrade to 2.31.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. UnratednpmAmendedPublished

    Reflected Cross-Site Scripting in jquery.terminal

    GHSA-2hwp-g4g7-mwwj

    Affected
    • npm jquery.terminal < 1.21.0
    Fixed in
    1.21.0· Vendor fix available
    Issue
    Versions of jquery.terminal prior to 1.21.0 are vulnerable to Reflected Cross-Site Scripting. If the application has either of the options anyLinks or invokeMethods set to true, the application may execute arbitrary JavaScript through crafted malicious payloads due to insufficient sanitization. Recommendation Upgrade to version 1.21.0 or later

    Recommended action: Upgrade to 1.21.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →