Skip to content

← Public intelligence

npm package

jquery.json-viewer

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.1npmAmendedPublished

    Cross-site Scripting in jquery.json-viewer

    CVE-2022-30241 · GHSA-qp2q-6h9j-jg2r

    Affected
    • npm jquery.json-viewer < 1.5.0
    Fixed in
    1.5.0· Vendor fix available
    Issue
    The jquery.json-viewer library before version 1.5.0 for Node.js does not properly escape characters such as < in a JSON object, as demonstrated by a SCRIPT element.

    Recommended action: Upgrade to 1.5.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. UnratednpmAmendedPublished

    Cross-Site Scripting in jquery.json-viewer

    GHSA-v9wp-8r97-v6xg

    Affected
    • npm jquery.json-viewer < 1.3.0
    Fixed in
    1.3.0· Vendor fix available
    Issue
    Versions of jquery.json-viewer prior to 1.3.0 are vulnerable to Cross-Site Scripting (XSS). The package insufficiently sanitizes user input when creating links, and concatenates the user input in an <a tag. This allows attackers to create malicious links with JSON payloads such as: This may lead to arbitrary JavaScript execution in a victim's browser. Recommendation Upgrade to version 1.3.0 or later.

    Recommended action: Upgrade to 1.3.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →